Crash and won't Reopen

I updated and now progam wont open

Tell me more. Do you know what version of the app you updated to? What happens when you try to open the app? Nothing at all?

it just does this then shows the crash log
It looks like you encountered a crash during the last session.

Version: 2.1.20 (678)

Yeah it looks like the crash is happening so soon I’m not getting any identification attached to it so I can tell which one is yours.

Can you try and rename the Rekord Buddy folder in your Music folder and launch the app? Just trying to make sure there isn’t some kind of data corruption causing this in the first place.

Process: Rekord Buddy 2 [8972]
Path: /Applications/Rekord Buddy 2.app/Contents/MacOS/Rekord Buddy 2
Identifier: audio.next.RekordBuddy2
Version: 2.1.20 (678)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: Rekord Buddy 2 [8972]
User ID: 501

Date/Time: 2019-11-25 11:00:12.034 -0500
OS Version: Mac OS X 10.13.6 (17G65)
Report Version: 12
Anonymous UUID: B2EF006C-F803-A6C6-095E-DDE8CB67449B

Sleep/Wake UUID: CAA9C19C-4D7A-4939-94A4-C868DD70891C

Time Awake Since Boot: 48000 seconds
Time Since Wake: 900 seconds

System Integrity Protection: enabled

Crashed Thread: Unknown

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000008
Exception Note: EXC_CORPSE_NOTIFY

Termination Signal: Segmentation fault: 11
Termination Reason: Namespace SIGNAL, Code 0xb
Terminating Process: exc handler [0]

Backtrace not available

Unknown thread crashed with X86 Thread State (64-bit):
rax: 0x0000600000321680 rbx: 0x00007ffeefbfd1c0 rcx: 0x000000001fffffc0 rdx: 0x000000001ffffec0
rdi: 0x0000000000000000 rsi: 0x00006000000020a0 rbp: 0x00007ffeefbfd160 rsp: 0x00007ffeefbfd160
r8: 0x0000000000000000 r9: 0x0000000000000000 r10: 0x0000000000401000 r11: 0x0000000040100000
r12: 0x00006000002c4050 r13: 0x00000000f1b1a580 r14: 0x00006000000020a0 r15: 0x00007ffeefbfd1c0
rip: 0x00000000f1058b14 rfl: 0x0000000000010246 cr2: 0x0000000000000008

Logical CPU: 0
Error Code: 0x00000004
Trap Number: 14

Binary images description not available

External Modification Summary:
Calls made by other processes targeting this process:
task_for_pid: 2
thread_create: 0
thread_set_state: 0
Calls made by this process:
task_for_pid: 0
thread_create: 0
thread_set_state: 0
Calls made by all processes on this machine:
task_for_pid: 660958
thread_create: 0
thread_set_state: 0

Model: MacBookPro11,1, BootROM 151.0.0.0.0, 2 processors, Intel Core i7, 3 GHz, 16 GB, SMC 2.16f68
Graphics: Intel Iris, Intel Iris, Built-In
Memory Module: BANK 0/DIMM0, 8 GB, DDR3, 1600 MHz, 0x80AD, 0x484D54343147533641465238412D50422020
Memory Module: BANK 1/DIMM0, 8 GB, DDR3, 1600 MHz, 0x80AD, 0x484D54343147533641465238412D50422020
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x112), Broadcom BCM43xx 1.0 (7.77.37.31.1a9)
Bluetooth: Version 6.0.7f10, 3 services, 27 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en0
Serial ATA Device: APPLE SSD SM0512G, 500.28 GB
USB Device: USB 3.0 Bus
USB Device: Apple Internal Keyboard / Trackpad
USB Device: BRCM20702 Hub
USB Device: Bluetooth USB Host Controller
Thunderbolt Bus: MacBook Pro, Apple Inc., 17.2

No need to post crash logs here, I can’t process them from the forums.

I’m posting a build today with more debug info for me as to what is going on. There are a few of you guys with crashes right from the start but each seems to be for a different reason. I’m still soldiering on though, we will figure this out.

Ok, I thought you would be able to see the problem by postong. Thank you for replying

No worries. I try to make it as easy as possible.

Make sure you try 2.1.21 and reproduce the issue if you are still seeing it. It sends me info every time.

UP & RUNNING - one thing my Rekordbox library does not show up. Without sync how can I drag and drop.

What do you mean by not show up? Do you see no rekordbox item in the sidebar or do you mean it’s empty?

If you’re seeing an empty collection, there is a nice section in the manual named viewing your Rekordbox collections which may be of assistance :slight_smile:

1001% my bad. I read the getting started and everything below it over and over and never saw that above it. THANKS & SORRY!!! for that last post

haha, it’s ok… I’m doing some tutorial videos soon. Those will help a lot.

I have a similar issue - updated from an older version to the latest build - the app loads then disappears. I tried renaming the folder as described above, same issue occurs. I am running mac os catalina version 10.15.1. Any help would be greatly appreciated.

@djlockstar Your issue is this one I believe.

I can’t get to previous version…following your instructions step by step. Any other means to get the earlier version? Thank you!

There is no mean to get the earlier version. I’m just pointing you to the thread where I will be posting updates on your issue. I’m working on it as we speak :slight_smile:

Got it! Sorry for the confusion! Thanks for your help!

1 Like