NEED HELP! Open Key Notation, Copying from Traktor to Rekordbox

Hello Music Lovers! :slight_smile:
I need a little help. (I bought Record Buddy last week…)

My primary collection is my TRAKTOR Collection.
I want to copy my entire Traktor Collection with all Beatgrids, Cue Points and Keys (Keys are detected by TRAKTOR in “Open Key”) directly to Rekordbox (Export Mode).

My Problem:
Open Key Notation is correctly displayed in Rekord Buddy

But not in Rekordbox :frowning:

Target is to display “Open Key Notation” in Rekordbox/CDJ.
Can you help me?
I think my Rekordbox Settings are right:

My Rekord Buddy Settings:


Versions:
Rekord Buddy: 2.1.17
Rekordbox: 5.7.0
Traktor: 3.2.19

Thank you so much for your help and for Record Buddy!
And sorry for my English… :wink:

Cheers,
Hannes (from Germany)

I had a similar Problem When syncing from Serato to Rekordbox.
I had to choose alphanumeric and Not Classic in the rekordbox settings.
Maybe this works for you too.

Greets from Germany :wink:

Thank you!
When I change to “alphanumeric” there are no changes in the Rekordbox xml :frowning:


“Open Key Notation” is still not displayed in the “Key” Column of Rekordbox xml…
I don´t know what to do…

The change to alphanumeric only caused a switch in the Recordbox Collection. But not in “Open Key”

:

Greets, Hannes

This seems like a rekordbox issue. Let me try and repro it here.

This turned out to be something that was badly explained but I did change the way it was done in order to make it easier to understand.

Basically, before, the preference setting would also affect the way yes where displayed in other collections. So you would see the keys in Camelot notation even if they weren’t in Camelot in the collection. This was confusing so I changed it.

Starting in 2.1.18, the keys in any collection other than Rekord Buddy will always be displayed in their native notation (whatever they are in that collection). When copying a track to a collection that supported musical keys as a string, the string will reflect the notation choosen in Rekord Buddy’s preferences.

This should make more sense now.