Rekord Buddy Crashes Everytime on Export to Serato

My Rekord Buddy Version: 2.0.29
My OS Version: High Sierra 10.13.6
Steps required to reproduce the problem:

  1. Export XML from Rekordbox
  2. Launched Rekord Buddy
  3. Successdfully synced my Rekordbox Library and Playlist

What I expected to happen: Tried to Export my Rekordbox Library over to Serato

What actually happens instead: Rekord Buddy crashes as soon as I try to export to Serato, stating I’ve found a critial bug.

I did a clean install of Serato and wiped my previous Database so I really don’t understand why it’s crashing on every attempt.

I’d really like to Sync up my Library between Rekordbox and Serato. Any idea what might be causing this to happen? Thanks in advance.

Tried to add the crash code but cannot do to character limits. I have it saved and can send it using an alternate method, please just let me know how to send it and where.

Thanks.

I have same problem, it crash all the time when I try to export to Rekordbox from Serato. Works perfect to import - but not export. When he tries to write, it crash. I have send a crash rapport more then once today from the app. Tried with latest 2.0.x and even the old beta that worked before, same same…

1 Like

Yup, so aggravating! Rekord Buddy 2.0 doesn’t work, the Beta doesn’t either. One crashes the other just locks up. Good luck with the subscriptions, I know I won’t pay again unless this becomes stable. Just wasted hours trying to get it to work. Guess I’ll just set all my grids and cues manually, it will take time but at least it works!!!

@dvjstefan and @DJMikeT The current 2.1beta is pretty stable for most people. Can you describe what issues you are currently having with the beta?

As a side note, don’t spend hours trying to make it work if it’s a crash issue. Just report it here and let me help you step by step in identifying the problem. It’s always issues that only happen in a given situation/setup and the hardest part is identifying the cause if it’s not reproducible here. I have a new issue reporting system in the latest beta that allows me to grab info from the user’s situation when an issue happens. This will help me fix problems like this much quicker.

Hi,

I have been trying to import new MP4 files (worked like a charm the first time, a couple months ago). I have tried with deleted the old databas and only kept the new imported from serato. Everything looks perfect when I started to export to Rekordbox.

Doing Exporting Tracks… Looks perfect… But then… Saving Rekord Buddy database…

“Somethign wonderful has happend, You found a cricitcal bug.” and then i pressed “Send crash log on next launch”.

And with beta 2.1 same happens, but can’t send it to you - only Apple i think. You should have a crashfile from me i guess.

//Stefan

So on the beta version, the only way I could get Rekord Buddy to see my playlist was to export the xml and then rename it to match the default xml within Rekordbox and overwrite it there. Then when I opened Rekord Buddy it would see all the playlist but when I try to view and tracks within the playlist then Rekord Buddy becomes unresponsive, the little beachball icon just sits there and spins and I have to force quit the program. I’d really like to at least get the beta working. I tried dragging the xml into Rekord Buddy like your video show but that didn’t work either. Am I missing something?

I’ll look for the crash log on my end. What are you doing when the crash happens in 2.1? Dragging something onto a rekordbox collection or saving changes?

I’m assuming you mean an XML file you exported from rekordbox? Try dropping the file itself onto the rekordbox collection in Rekord Buddy. If you check out the manual in the help menu, it explains this step by step.

Let me know what happens when you do that.

I did this:

1 - Started Serato, added a few new crates. Created a new top crates and added my folders into that.
2 - Exit Serato, started Rekord Buddy 2.1 Beta
3 - Imported files into Rekord Buddy, worked perfect.
4 - Exported files TO rekordbox - Started to “Exporting Tracks…” (took a couple of hours) :skull_and_crossbones:
5 - When It has exporting all tracks to somewhere
6 - Exporting done - it started to “Saving Rekord Buddy database…” And then it crashed…

Hello Damien,

I still cannot get Rekordbubby to work, even with your latest version of 2.1 I’m still having the same issue.

This is what I’ve tried.

  1. I completely uninstalled Rekordbox (5.7) and all user data and settings.
  2. Reinstalled Rekordbox
  3. Restored my Rekordbox collection & database from backup.
  4. Exported rekordbox.xml to My Documents folder.
  5. Went into Advanced settings on Rekordbox and pointed to path to the xml file in My Documents Folder.
  6. Closed Rekordbox and Launched RekordBuddy.
  7. Dragged rekordbox.xml file into Rekordbuddy Rekordbox Collection within the program.
  8. Expanded Rekordbox Collection and all Playlists are visable.
  9. Tried to Click on a Playlist to reveal tracks and Rekordbuddy becomes unresponsive.

I even moved my entire collection from my Media Drive to the main OS Drive thinking maybe it was a path issue but the exact same thing happens no matter where the music collection is stored.

So frustrated as to why this will not work, I’m pretty good with computers but this is driving me nuts!

You are describing a 2.0 workflow. Can you upgrade to Rekord Buddy 2.1 and let me know what issues you are seeing?

Don’t re-install apps when trying to diagnose issues unless a developer tells you to do that as a last resort… It’s a bad habit from Windows but it only confuses thing more and could hide problems without solving them.

First, when you drag an XML on top of a rekordbox collections, this updated the bridge file that rekordbox uses by default. Don’t make rekordbox use the one in your Documents because that file will not be updated by Rekord Buddy. Only the default bridge one will be. Make sure you set rekordbox to use the default path. You can find info about this in the Rekord Buddy Manual (Help Menu) in the rekordbox section.

Now, it looks like your XML has something funky that I’m not handling well. Don’t get frustrated, this is probably nothing you can diagnose or fix by yourself. Can you zip up that XML file and send it me via DM? I’ll try to reproduce the issue here.

As a side note, this is why it’s better to start separate threads for separate issues. Otherwise it’s really hard to follow the conversation when multiple issues are discussed at the same time.

Ok good news, I finally got tracks to show without RekordBuddy crashing or locking up.

  1. I set the xml back to rekordbox default location, but there where no playlists present.
  2. I then export my xml to My Document and named it exactly the same as the default.
  3. I then renamed the default to rekordbox (original).xml and then put the exported file in the default location. I only renamed the original instead of overwriting in case I ran into a problem.
  4. Launched RekordBuddy and expanded the Rekordbox Collection and initially it crashed.
  5. Launched again but didn’t expand and then dragged the xml file from the default location onto the Rekordbox Collection tab and “FINALLY” it worked.

I’m going to move my collection back to my 2TB SSD and hopefully everything still works.

At least it’s moving in the right direction!

That’s great but you didn’t follow the steps I provided to you unfortunately. I can only help you if you help me with the info I need :slight_smile:

Don’t rename files or overwrite anything. Just export a fresh rekordbox xml somewhere, and drag that file on top of the rekordbox collection in Rekord Buddy itself. If that generates an issue (“Something wonderful…”) or a crash, zip up and send me the XML file via DM.

Damien,

I’m starting a new topic so we can be on the same page, things you are asking me to do do work with want I’m trying to accomplish. Going to go into detail in the new thread and hopefully we can get this sorted.

1 Like