Rekord Buddy only import half of Traktor collection?


My Rekord Buddy Version:


My OS Version:


Steps required to reproduce the problem:

See video link com/open?id=1uYh-nEubLjxD56Hlp5La_dDk4ZwiiAGv

What I expected to happen:

Basically I follow the steps given in forum posts and the manual for setting up and basic workflow of rekord buddy 2 and my serato library would import prior (serato is not my main library/software, traktor is) but not my traktor library.

What actually happens instead:

Import runs its course but no files appear, some playlists transfer but only a handful of my many that I have present in traktor.


Can you show me a screenshot of those playlists in Traktor? More importantly where they are located in the Traktor sidebar.


Here I’ve included traktor, serato, and rekordbox, I don’t have those 3 folders anywhere in traktor after skimming mine, more importantly the software doesn’t even attempt to import any of my playlists in traktor. Let me know what you’re thinking, thanks!



mmm… It looks like 2.0 doesn’t think the playlists are out of sync.

Can we try something? Download the 2.1beta and try to import from Traktor then export to Serato. Let’s see if that syncs correctly and we can go from there.


No difference, I’ll attach some pics of settings and the window but still the same result sadly.
EDIT: forgot to include serato pic


In the Traktor preference, you have it setup to use some custom collection file location. Are you 100% sure this is where Traktor is storing its database? This should always be set to use the main Traktor collection file.


that file path is the custom one i have set in the traktor preferences and have always use so I can dig through the NI/traktor root folders to see if theres a mirror of it or a root library nml/m3u type file if that’s what you mean, let me know I’ll be looking!


Yeah I’m wondering if it’s not using the wrong Traktor data for some reason. Worth a look.


is this what you’re talking about? I found it in documents/native instruments/traktor 2.11.3

if this is it rekordbuddy 2.1 doesn’t allow me to select it in the preferences for the library

additionally this is where the traktor root directory leads in preferences, the main music folder is the file path int he settings screen shot prior


wait i’m an idiot i got it to go with the new file path lol, it seems to be actually scanning, fingers crossed the whole library imports.

Yup all of the ~3k files importing! didn’t realize it went off the nml collection files not actual music files.


You’re not an idiot, it’s an easy mistake to make. Let me know how it goes :slight_smile:


Okay so further issue now, I’ve got the entire library in rekordbuddy, have an .xml file specially saved for rekordbox tried to export to rekordbox (with all setting in the manual saying to tick, ticked) and nothing in rekordbox, so my question is will 2.1 be saving a new .xml for me to link to rekordbox or does it rewrite the .xml i have from rekordbox? or is it neither lol


Exporting to rekordbox doesn’t write directly to the rekordbox collection, because of the way rekordbox worls unfortunately.

Did you import the changes via the XML bridge?


i’ve got it working now i wanted to try and use a custom xml path but i eventually reverted to the default one for simplicity sake, appreciate all the help!


Glad you got it figured out. The new 2.1 flow will make this easier (drag and drop between collections).