Serato to Rekordbox Playlist - not working

My Rekord Buddy Version:

My OS Version:
Ver 10.13.6
Steps required to reproduce the problem:

  1. List item

What I expected to happen:
When I’m importing playlists from rekordbox.xml in Rekordbox, it should popups under the Playlists- with the same name as the “playlist” from rekordbox.xml with all the tracks inside.

What actually happens instead:
I import the playlist from rekordbox.xml - all files imports to the collection, and i’m getting a playlist with correct name. BUT, there are no files into the playlist.

Why??? ;(

1 Like

Does this happen when you try to import individual playlists?

Yes, first i took one “folder” with like 20 playlists in. Then i delete those because they all was empty, but import and analyze all the tracks so I could find them in the collection.

2nd test - i took only one small playlist and same thing, tracks in collection but playlist was empty again :frowning:

//S

Which version of Rekord Buddy are you using?

I’m using v2.0.22(217)

I have tried to update from the program, but I’m getting an Update Error when I try.
I don’t want to use a beta version, because I have all my songs on a external hdd - what I have understand, beta version dosen’t work if you have the songs on a external hdd.

//S

You have the latest stable version.

This sounds like a path conversion issue (it thinks the files don’t exist so the playlists end up empty). In order to get one more data point, you could try the latest stable beta. That one works with files on external drives (I know the versions are confusing right now, I’m working on fixing that).

Let me know if the results are the same.

Hi,

I have trying all evening, but same results :frowning:

any idea?

If you have an external hard drive, is it plugged in and mounted when you do the sync?

Yes, and it’s plugged in all the time and always - because i have all the music files on it.

Is there possible to enable some debugging/logging and see what goes wrong?

Hi - is it possible to get a working rekordbox.xml, just with a few rows. So I can check against mine if its correct?

Is your music stored in iTunes, or in the app collection?

I don’t using iTunes, so its the app collection.

Can you DM me a zipped version of your rekordbox.xml file and let me know the name of one playlist that displays the problem so that I can try and reproduce here?

1 Like

Can you try the latest build? I fixed an issue with file paths that may be the same one you encountered. Otherwise I’ll keep on looking.