Traktor Beatgrids vanish


#1

My Rekord Buddy Version:
Currently 2.1 Beta

This error has been present since I first used Rekordbuddy. Before version 2.0 went live. Sorry I waited so long to post this!

My OS Version:
OSX 10.12.5

Steps required to reproduce the problem:

  1. Sync my LARGE Traktor library with Rekord Buddy
  2. Takes a while but all seems to work well. Cues sync to Serato fine. Crates all show up in both platforms

What I expected to happen:

Beatgrids, ID3 Tags, and all metadata should stay intact a in the Traktor collection. Tracks previously analyzed in Traktor should stay that way. Locked tracks should have the beatgrid absolutely unchanged.

What actually happens instead:

  1. After a bit of playing I’ll always come across tracks that I KNOW I’ve played before, prepped and beatgridded at some point but the beatgrid is GONE
  2. I’ve repeated this process after locking the beatgrid for tracks i want to protect in Traktor before the initial Rekorbuddy sync with the same results
  3. I need to manually unlock the tracks, analyze them again, re-adjust beatgrid, and lock them again.
  4. Usually this all happens on the fly in the first 20 mins of a gig as there’s no predicting which tracks will stay gridded properly and which won’t
  5. If I rollback to the backup version of my collection before the Rekordbuddy sync, everything is fine, but I’d prefer to do all my tagging outside of Traktor so I can use any platform

#2

Is this happening in Traktor or Serato?


#3

Traktor. I only use Serato when I’m playing with other DJs


#4

Rekord Buddy currently doens’t honor the lock flag in any of the programs. This is something that will be changed in a future release allowing users to select whether to ignore it or not.

In a lot of cases, people will want to ignore it as they may be syncing a track that has that flag on too and just update the metadata but I agree it would be better to leave it at the user’s choice.


#5

Hi there!
Same thing happen to me, but with rekordbox.
I always prepare my tracks in rekordbox and then import to rekordbuddy and the export to traktor.
In traktor i set correctly my grid’s and cues (cues that i must delete twice before setting correct one, this being reported a year ago with video) and the lock the grids and then in rekordbuddy import the changes I’ve made in traktor.
The strange thing is that every time I add new traks in rekordbox and impoterd in rekordbuddy and then exported to traktor, all my previous beatgrids and cues are back at where before setting them correctly, even if the changes where synced to rekordbuddy.
An example is let’s say I’ve exported my cues and loopcues to traktor, the cues and loop cues are marked only as flags, and are exported both of them, cues and memory cues witch are placed’s in the same spot, even in rekordboddy I’ve unchecked duplicate memory cues as hot cues on export. I set the grid’s correctly, the cues I must delete twice because on the same spot I have cues and memory cues, and let’s say my first cues is set as load cue and second as loop cue, and are numbered as ‘1’ and ‘2’. I save my work made in traktor, by importing changes in rekordbuddy, but every time sync rekordbox with rekordbuddy, all my previous work made in traktor is back to start.
What might be wrong???
Is frustrating, I’ve already done my collection 4 or 5 times (my luck was that I don’t have a large collection) but I give up doing it again because is time consuming.
Thanx! And excuse my english!


#6

I’f you’re going back and forth, editing in different software it might be worth switching to the 2.1 beta… It has a better sync system which lets you control more.


#7

Hi there!
I’m already on 2.1 beta.
The problem is present from the beginning of rekordbuddy 2.


#8

I think we’re talking via support? I won’t double up our conversation. :slight_smile: