Traktor Export to Rekordbox, Multiple Key Notation

My Rekord Buddy Version: v2.1.36

My OS Version: macOS High Sierra 10.13.6
Traktor Version: 3.2.1.9
rekordbox Version: 5.8.3

Steps required to reproduce the problem:

  1. Add tracks to Traktor collection and Analyse them.
  2. Key is set to Open Key Notation in Preferences.
  3. Open Rekord Buddy, drag playlist from Traktor to Playlist in Rekordbuddy, note that all tracks are in Open Key Notation.
  4. Open Rekordbox, open XML bridge
  5. Right click on the playlist from Traktor and Import the playlist to Rekordbox collection.
  6. Open the playlist in Rekordbox.

What I expected to happen:
The newly added playlist in Rekordbox should show all tracks with Open Key Notation, as they are in Traktor.

What actually happens instead:
Most of the tracks show Open Key Notation (1m, 2m, 3d) , but about 10% show Classic Key Notation (F, Gb, Am). The ones that show Classic Key Notation seem to appear in small groups next to each other.

Three tracks recently imported to Traktor do not show any key information in Rekordbox, but the key is present for each track in Traktor, also Open Key Notation.

After noticing this, I did change the Rekordbuddy Preference for Traktor to use the Key and not Key Text. But I have since performed the above steps, and Rekordbox is still showing some tracks in Open Key and others in Classic Key.

My workaround at this point is to write all tracks from Rekordbox that show Classic Key on a piece of paper, look them up in Traktor, and write the corresponding Open Key on the paper. This does not work very well when searching for tracks by key on a CDJ 2000NXS, however, and requires looking at the paper during searches.

Thanks much for your help.

Thanks for the detailed report. Much appreciated.

Let’s try one track at a time. Let’s pick one that’s not working currently.

Is Traktor set to use key text or key in its Preferences?
In Traktor, for that track, what do you see in the Key section?
Is Rekord Buddy still set to use Key in its preferences and not key test?
In Rekord Buddy, in the Traktor section, what do you see in the Key field for that track.

Thanks much for the reply. Please see answers to your questions below:

Is Traktor set to use key text or key in its Preferences?

Preferences > Track Decks > Key

In Traktor, for that track, what do you see in the Key section?

2m under the “Key” column

Is Rekord Buddy still set to use Key in its preferences and not key test?

Preferences > Traktor > Read “Key” Field Instead of “Key Text” when reading from Traktor is ticked.

In Rekord Buddy, in the Traktor section, what do you see in the Key field for that track.

2m under “keys” column

In Rekord Buddy, in the Playlist section:

2m under “keys” column

In Rekordbox, in the Playlist section:

Em under “key” column

Another observation is that in Rekordbox, the imported playlist doesn’t appear in the folder it was under in Traktor. Instead, it’s at the end of all the playlists. Not sure if this makes any difference, but thought I’d mention it.

Greets from Berlin, and please let me know if you have any more questions or need additional information.

What is the musical key setting in Rekord Buddy’s preferences set to? Which notation?

In Rekord Buddy preferences, Key Notation shows: Open Key.

I am wondering if since “Read Key instead of Key Text” in Rekord Buddy > Traktor preferences wasn’t originally ticked, that Rekordbox could have analyzed the audio files and updated them with the Classic key notation. Then, when I later ticked the “Read Key instead of Key Text” box in Rekordbuddy preferences, Rekordbuddy didn’t update Rekordbox with the Open Key values?

But I don’t know why most of the files in Rekordbox would show open key, while some show Classic Key. I have only used Open Key with Traktor, so it has never been set to any other format. I didn’t have the issue with the older version of Rekordbuddy either, if that helps any. The key values had always showed Open Key in Rekordbox.

Please let me know if you have any more questions.

Find one track that doesn’t have the correct notation in rekordbox. Drag it again from Traktor to rekordbox in Rekord Buddy, save changes and then look at the track in the rekordbox XML in rekordbox.

Does it have open key now?

I chose one track in Rekordbox that showed the key as Em.
I drug that track to the same Rekordbox playlist in Rekordbuddy
I saved the changes in Rekordbuddy.
In Rekordbox, I looked at the same track in the playlist under XML and it showed 2m.
I right clicked on the playlist under XML and imported it after receiving a warning that “one or several lists with the same name already exist, do you want to replace them?”
Then I looked at the track in the Rekordbox (not XML) playlist, and it showed Em.

Next, as a further troubleshooting measure, I went back to XML and imported only the single track.
Then I looked at the track in the Rekordbox (not XML) playlist, and it showed 2m.

So, it appears that importing the whole playlist in Rekordbox XML did not update the key information, but importing the single track in Rekordbox XML did update the key to Open Notation.

One question here is whether “Import Playlist” only imports the folder name, or also all files within it?
As a further test, I went to the playlist in Rekordbox XML and pressed CMD-A to select all files.
Then I imported them and ticked “replace” for all.
After doing this, now all tracks show Open Key notation.

So basically, importing the playlist did not update the files within it to Open Key notation. Importing all the individual tracks within that playlist did update the files with Open Key notation.

Let’s verify one thing. Using that same track, can you delete it from rekordbox and then import the playlist? This sounds like a bug in Rekordbox itself.

Sure. First, I’d like to verify the steps to follow:

  1. In the Rekordbox Collection, delete the same file

  2. In Rekordbox XML, right-click on the Playlist and import it.

  3. In Rekordbox (non XML), view the Playlist to see if the song is included.

Please let me know if I’ve got it right, and I’ll try this. Thanks.

Actually just delete it from the rekordbox collection in rekordbox before importing it again from the XML (also in rekordbox).

Basically I think you are hitting a current bug in rekordbox where importing playlists from the XML doesn’t update the tracks correctly.

In Rekordbox, I deleted the same track from the collection.

Then under Rekordbox XML, I right-clicked on the playlist and imported it

Then I checked the playlist in Rekordbox (non XML) and the track was there with the key shown in Open Key notation format (2m). I hope this information is helpful.

So deleting the track then makes the import work correctly, right?

Apparently, as the track in Rekordbox that was deleted from the collection and then later imported through XML does indeed appear again in the Playlist.

Since I had previously imported all tracks again in Rekordbox XML using CMD-A, the key had already been updated to Open Notation. But at least it didn’t change back to Classic musical key.

The Playlist still shows up in Rekordbox at the end rather than in the folder where it was in Traktor, but that doesn’t matter much to me long as the tracks show up with the correct info such as bpm, markers, key, etc.

So it looks like you are seeing the current rekordbox issue with importing XML. I have a communication channel open with Pioneer in order to see if they can fix it.

Thanks much! I saved some screenshots of Rekordbox showing the differing key notations after the XML import, in case they might be helpful to anyone.

In the meantime, a workaround is to select all tracks in the playlist and “import all,” rather than choosing “import playlist.” Then all the audio files should show Open Key Notation in Rekordbox.

1 Like

Thanks for the tip!