[Win] Beta 2.2 Stuck with Rekordbox in the tree view, but xml giving error (no playlists or tracks)

I was moving my playlists form Rekord Buddy to Rekordbox (v 5.8.5.), but somehow now I’m stuck with no ability to use the xml bridge anymore. I can see Rekordbox in the Rekord Buddy tree view, but opening the triangle gives an error.

  1. Tested with one Playlist folder with a few playlists in it. Everything worked fine and could open the .xml in Rekordbox and checked that cue points transferred.

  2. After that I tried moving the majority of my collection, saved my work in Rekord Buddy, but it gave an error in Rekordbox and it didn’t show any playlists or folders in the tree Rekordbox view:

  1. Now if I try to open the xml in Rekord Buddy, I see this:

There is no “playlists”, only “All Tracks” in the tree view, but if I drop a track in there from Rekord Buddy collection, the program crashes.

  1. I tried to create a new xml file in Rekordbox, but Rekord Buddy doesn’t allow dragging and dropping a new xml, nor can I remove Rekordbox from the tree view and start from scratch, so I’m kinda stuck.

Checked in Notepad, and the xml has no tracks in it.

Okay, managed to sort things out.

I didn’t notice before, that when you hover over the Rekordbox collection in Rekord Buddy, it shows the location of the xml it is referring to. It was referring to the Rekordbox.xml in my AppData/Roaming/Pioneer/rekordbox folder, but the xml bridge file I originally used was located in my User/Music folder…

In conclusion, it seems the Windows version cannot handle custom locations for the xml file? Everything works, if I keep things in it’s default locations. Was just confused a bit, as I made Rekordbox look for the xml in my User/Music folder, but Rekord Buddy was only editing the AppData xml, and it seemed like no data was imported to Rekordbox.

Anyway, now things are working. :ok_hand:

EDIT: Still not sure why the things would corrupt the files…

More investigations:

  1. Things fall apart when I try to move large playlists with multiple levels of nested folders.

  2. Rekordbox can’t read the xml, and I get the error in the first post.

  3. Not even Rekord Buddy able to open the xml it created, even though it seems to have data. It gives an error if I leave the xml in it’s default location, but if I drag and drop the same xml from another location, it does nothing…

Not sure if multiple folders are the only culprit, as I managed to create and move playlists with multiple nested folders from Rekordbox to Rekord Buddy and back. But certain folders just break things…

:weary:

It’s usually better to use the default location which is in AppData but you can use another location as long as you make sure that rekordbox and Rekord Buddy use the same file. For Rekord Buddy you’ll need to make sure you drag the XML file in the sidebar so that it creates an entry with “User Location”. Rekord Buddy should work fine as long as it’s using the file you want it to use.

Tell me more about this. Is that when you see the corruption? Can you narrow it down to one simple operation to replicate this?

Also, What exact version number of the beta are you using?